求助,PHP版本切换后出现问题。

用户 killerser 4月前 730

           事情是这样,空间原本运行环境是这样的:


       由于需要使用相册插件,开发者要求PHP最低7.0以上版本。于是我让空间商版本切换PHP版本。切换版本后,空间中多了个web.config配置文件。这个文件存在时,就是PHP7,删除后就是PHP5.2.17。什么原理我也不明白。切换版本后,前台运行正常。后台无法登陆,一片空白,源码显示数字1。

       下图为PHP7环境

这个状态下,后台无法登陆,我测试了下在线安装程序

删除web.config配置文件,PHP变回5.2.17,一切又都正常。好吧,通过修改web.config配置文件达到修改PHP版本的目的

ZBLOG PHP在线安装程序显示可以连网了。但是下载不了,也可能解压不了??

好吧,不管它到底是下载不了还是解压不了了。我应该如何解决??是空间商PHP问题吗?还是组件不齐?由于没有办法在PHP7状态下运行安装文件,无法使用PHP自带探针查看缺少什么组件。

斌、朵♫恋

最新回复 (5)
全部楼主
  • 管理员 zx.asd 4月前 0
    引用 2
    看着好累,换个空间吧。

    短信已禁用,有事发贴。

  • 用户 killerser 4月前 0
    引用 3
    zx.asd 看着好累,换个空间吧。


    还有4年的寿命,我觉得还可以再抢救一下😂

    斌、朵♫恋

  • 超级版主 toyean 3月前 0
    引用 4
    在IIS的道路上,与其奉献的青春和时间,远不如Nginx或Apache来得实在。

    拓源主题 - 您身边的原创网站定制专家 丨 应用交流和开发工具可 点此加入ZBlog中国群

  • 用户 killerser 3月前 0
    引用 5
    toyean 在IIS的道路上,与其奉献的青春和时间,远不如Nginx或Apache来得实在。
    已换LNMP,看来看去,就看你顺眼

    斌、朵♫恋

  • 用户 killerser 3月前 0
    引用 6
    toyean 在IIS的道路上,与其奉献的青春和时间,远不如Nginx或Apache来得实在。
    看你的主题顺眼

    斌、朵♫恋

    • ZBlogger技术交流中心
      7
          
返回