今天更新了,一下应用中心,结果悲剧了,高手帮忙解决一下! 使用交流

用户 hubin0612 19天前 195


最新回复 (7)
全部楼主
  • 用户 hubin0612 19天前 0
    引用 2
    本人小白一个,就会按部就班,到底问题出哪了!网站可以正常打开,就是不能安装插件模板和打开应用中心了!
  • 超级版主 沉冰浮水 19天前 0
    引用 3
    网站设置 → 全局设置 → 开发模式

    沉冰浮水.tk | 我的咸鱼心←_←我大概率能够解决你所实际面临的问题(收费),然而”你提出的问题“却往往是另一个问题。

  • 管理员 zx.asd 18天前 0
    引用 4
    你是在用一个旧版本的php 7.3吗?更新到7.4或是把7.3再升级一下

    https://www.cnblogs.com/zdz8207/p/php-7-3-issues.html

    短信已禁用,有事发贴。

  • 用户 hubin0612 18天前 0
    引用 5
    网站设置 → 全局设置 → 开发模式  故障报的更多了 错误提示
    错误信息

    (2)E_WARNING : "continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"? (set_error_handler) (1.7.1.2980 (Tenet)) (Linux3.10.0; nginx1.20.1; PHP7.3.31x64; mysqli5.5.5; curl-o7.70.0; OpenSSL1.0.2u)
    文件位置

    /www/wwwroot/zlog/zb_users/plugin/AppCentre/function.php
    51        die();
    52        break;
    53        case 'search':
    54        if (trim(GetVars('q', 'GET')) == '') {
    55        continue;
    56        }
    57        
    58        $s = Server_SendRequest(APPCENTRE_URL . '?search=' . urlencode(GetVars('q', 'GET')));
    59        echo str_replace('%bloghost%', $zbp->host . 'zb_users/plugin/AppCentre/main.php', $s);
    60        break;
    堆栈跟踪

    4        /www/wwwroot/zlog/zb_users/plugin/AppCentre/main.php
    ( 6 ) require()
    require dirname(__FILE__) . '/function.php';
    请求数据

    $%_GET = Array
    (
    )
    $%_POST = Array
    (
    )
    $%_COOKIE = Array
    (
        [__guid] => 197452841.1249122612472476400.1637062286560.2024
        [http304ok] => 1
        [addinfo] => {"chkadmin":1,"chkarticle":1,"levelname":"\u7ba1\u7406\u5458","userid":"1","useralias":"admin"}
        [timezone] => 8
        [monitor_count] => 756
    )
  • 用户 hubin0612 18天前 0
    引用 6
    zx.asd 你是在用一个旧版本的php 7.3吗?更新到7.4或是把7.3再升级一下 https://www.cnblogs.com/zdz8207/p/php-7-3-issues.html
    降7.2升级7.4问题一样在
  • 用户 hubin0612 18天前 0
    引用 7
    解决了!我把应用中心插件的文件删除了,然后官网下载的程序,把没有升级的应用中心插件,上传上去!搞定的!
  • 管理员 zx.asd 17天前 0
    引用 8
    hubin0612 解决了!我把应用中心插件的文件删除了,然后官网下载的程序,把没有升级的应用中心插件,上传上去!搞定的!

    看到了,你这个应该是用的很老版本,大概是2015年版的应用中心客户端,才会报错的。新版本的function.php没有continue。你再升级也不应该出问题的。

    短信已禁用,有事发贴。

    • ZBlogger技术交流中心
      9
          
返回
发新帖