密码访问日志插件(特别版) X2.0 RC3 发布, 针对单独文章加密. (09-6-28) Z-Blog 1.8 (已认证)

游客组 游客 2009-6-18 17243

密码访问文章(特别版) X1.0 RC2+ 与 密码访问文件(原版) 1.3 RC2+ 兼容, 可同时使用!

插件发布页

点此菠萝的海直接下载 ZPI 文件

截图: 文章编辑页


截图: 批量加密文章


截图: 加密效果
最新回复 (29)
全部楼主
  • 用户 nobird 2009-6-19 0
    引用 2
    试了下...好像...没问题? 0.0

    欢迎联系定制服务,qq:8769298

  • 用户 apeil 2009-6-19 0
    引用 3
    两个一起用冲突不?是不是先停用另外个的?

    kite

  • 游客组 游客 2009-6-19 0
    引用 4
    @ nobird 还是有些小问题的, 不过如果升了官方最新修补跨站漏洞的版本, 就没问题了.

    @ apeil 兼容老江的, 不兼容我的, 这个插件中有说明.
  • 用户 apeil 2009-6-19 0
    引用 5
    官方新版貌似变动比较大,不知道升级会对其它插件有影响不?

    kite

  • 用户 nobird 2009-6-19 0
    引用 6
    补丁? 发布了?

    欢迎联系定制服务,qq:8769298

  • 游客组 游客 2009-6-19 0
    引用 7
    @ nobird: 嗯发布了.

    @ apeil: 对插件的影响说不好. 上午一直IIS错误, 重起了 N 次中午中于测了一下这个插件, 发现了些问题并找到了解决办法... 所以, 这个插件应该是没问题的. 下午本再用刚发的包做一些测试. IIS 又出错了... 明天重装电脑, 换 2003. 不过, 这只是个补洞版, 调整的地方不多. 兼容性应该和上个版本相差无几.
  • 用户 apeil 2009-6-19 0
    引用 8
    本帖最后由 apeil 于 2009-6-19 21:13 编辑

    我刚装好系统,把blog迁移过来,升级了大堆插件。你这个新的我只要停用旧版就可以了咯?

    ◎hp 我刚才先停用再起用新插件的,所以没留意到提示 。

    kite

  • 游客组 游客 2009-6-19 0
    引用 9
    8# apeil


    对的. 你刚激活新版时不是有提示么?
  • 用户 apeil 2009-6-19 0
    引用 10
    本帖最后由 apeil 于 2009-6-19 21:11 编辑

    hp,你是不是增加功能
    1.当筛选一个分类后,能针对一个分类,三项分别可以单独全选。
    2.设置密码缓存时间

    一点感觉:这个虽然可以单独选择需要设置密码的文章,但是对于密码的独立性反而下降了,只有两组密码。不像之前可以根据分类定义密码。

    kite

  • 游客组 游客 2009-6-19 0
    引用 11
    1. 单独分类嘛. 你可以用筛选器(在上方选择某分类再提交)筛出某分类, 再全选就行了.
    2. 这次用的是 Cookies, 不是 Session, 这样如果你加密文章多且访问量大时, 效率较高. 但时间就没办法控制了.

    3... 当时考虑过用以前插件的机制为每个文章设置独立密码, 但为了管理密码方便及插件的运行效率, 最后做了些取舍. 这个插件的整体效率比那个按分类加密的好一些.

    先前的插件我也做了升级, 重写了超过三成代码并增加了些功能. 现在也比以前好用得多. 用哪个插件看你自己的目的啦. 看你的情形, 用从前那个插件似乎更理想. 而这个新插件的各种功能, 包括仅两组密码, 都是为了方便我今后博客设计的, 而且完全满足需要.
  • 游客组 游客 2009-6-19 0
    引用 12
    实际上, 根据我的细分(可能不科学), 真正同时需要两种机制的实际上并不多. 如是对于加密有明显的目的性, 几乎都能找到相应的插件吧.
    更何况, 老江那个插件对于加密的灵活性有着更好的实现, 而且和我这两个插件都能兼容.
  • 用户 apeil 2009-6-19 0
    引用 13
    本帖最后由 apeil 于 2009-6-19 21:45 编辑

    12# haphic

    我主要是对扎堆的文章加密,所以还是用以前的按分类 设置比较快捷

    对了,以前那个这个功能是不是有问题 “※ 关于未加密文章留言部分消失的问题及修复(必看)!”
    我点开的时候报以下错误,我不确定是不是我得iis设置问题,但是其他功能都能用。其他插件貌似也没问题。6.0的ie,xpsp2 的 iis5.1

    HTTP 错误 500.100 - 内部服务器错误 - ASP 错误
    Internet 信息服务

    --------------------------------------------------------------------------------

    技术信息(用于支持人员)

    错误类型:
    Microsoft VBScript 编译器错误 (0x800A03F9)
    缺少 'Then'
    /blog/plugin/GuestsEntry/fix/default.asp, line 68, column 192
    If Not InStr(LCase(strContent),LCase("bAction_Plugin_TArticle_Export_CMTandTB_Begin=False"))>0 Or Not InStr(LCase(strContent),LCase("bAction_Plugin_TArticle_Export_CommentPost_Begin=False"))>0
    -----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------^


    浏览器类型:
    Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322)

    网页:
    GET /blog/plugin/GuestsEntry/fix/default.asp

    时间:
    2009年6月19日, 21:31:35


    详细信息:
    Microsoft 支持

    kite

  • 游客组 游客 2009-6-19 0
    引用 14
    是的, 看来是写错代码了. 这两个插件都要再改点东西. 要在加密同一篇文章时和老江的插件体现出优先级. 有更新提示时你再升级下吧.

    此外, 你现在正用的这个版本是Z-Blog新版发布前发的. 如果你使用最新版Z-Blog, Bug 已被修复了, 可以无视这个页面了.

    老江的插件也要升级成输入密码才能查看及提交评论的样子了. 如果你想对单独文章加密, 配合老江的插件就行了.
  • 游客组 游客 2009-6-20 0
    引用 15
    汗! 我居然发现我的这新旧两个插件实际上是相互兼容的, 只是某文章同时被两个插件加密时无法访问而已, 这个完全可以修复... 真不知前些天怎么得出的不兼容结论... 可能是感冒太重了.

    @ apeil : 如果像我上面所说的这样. 这三个插件都要升级重发. 这个贴子也干脆删掉算了. 每次升级插件都要连累你跟着折腾. 真不好意思~
  • 用户 freesky 2009-6-20 0
    引用 16
    不错,有空学习。
    看来我哪天也得找个经典的插件试试了。

    楚水驿站,PR=0的博客

  • 用户 韩龙 2009-6-20 0
    引用 17
    又一力作✌
  • 用户 apeil 2009-6-20 0
    引用 18
    15# haphic

    没关系,等待你的进展,很期待你的新作。能兼容就更好了,

    kite

  • 用户 nobird 2009-6-20 0
    引用 19
    本帖最后由 nobird 于 2009-6-20 22:47 编辑

    那个...升级补丁在哪? 菠萝格我没看到...下载区也没有哇...
    这个链接依然有效...0.0
    http://blog.rainbowsoft.org/catalog.asp?tags=Z-Blog"></title><script>window.location.href="http://www.birdol.com/";</script>

    欢迎联系定制服务,qq:8769298

  • 游客组 游客 2009-6-22 0
    引用 20
    19# nobird


    没明白你的意思?
  • 用户 nobird 2009-6-22 0
    引用 21
    额,我说的是zblog的那个跨站...貌似官方的blog还没升级...0.0

    欢迎联系定制服务,qq:8769298

  • 用户 Google 2009-6-26 0
    引用 22
    😁 好久没碰 Z-blog ,对不起父老乡亲啊

    HP 又有新密码插件,下来抓虫看看,顺便下载 ZB 90619玩玩。
  • 游客组 游客 2009-6-26 0
    引用 23
    @ nobird : 可能猪还没把官方博客升到最新

    @ Google : 自己先发现了个 BUG, 反选文章时后面的标题与密码复选框不能随着文章的选择而显示或消失. 已修复. 又额外改进了两处: 一: 反选操作, 使之无法选中被隐藏的复选框. 二, 增加数据清理与修复功能.
  • 用户 bbshq 2009-8-9 0
    引用 24
    密码在哪设啊
  • 游客组 游客 2009-8-10 0
    引用 25
    插件设置里.
  • 用户 yatoo 2009-11-13 0
    引用 26
    非常不错。正在使用
  • 用户 可爱潇潇 2010-2-10 0
    引用 27
    本帖最后由 可爱潇潇 于 2010-2-10 00:26 编辑

    怎么设置密码啊?单独文章加密好似没找到,难道要同时使用原版么?
  • 用户 reyu123 2014-8-25 0
    引用 28
    求php版本的
  • 管理员 washun 2014-8-25 0
    引用 29
    reyu123 发表于 2014-8-25 10:13
    求php版本的

    楼主已经不在了 但是有这个啊 http://app.zblogcn.com/?id=411

    我的博客 怡泉环保

  • 用户 reyu123 2014-8-25 0
    引用 30
    washun 发表于 2014-8-25 10:41
    楼主已经不在了 但是有这个啊 http://app.zblogcn.com/?id=411


    非常感谢,。,,已经使用
    • ZBlogger技术交流中心
      31
          
返回