zblog php 1.1 安装出错

用户 剑齿虎 2014-2-9 1945

(8) Undefined offset: 6




http://desc.yuxiaobo.cn/zb_install/ 求高手分析
最新回复 (10)
全部楼主
  • 管理员 zsx 2014-2-9 0
    引用 2
    404         

    不理世事

  • 用户 剑齿虎 2014-2-9 0
    引用 3
    zsx 发表于 2014-2-9 11:40
    404         


    网站是托管在 youhosting 的
  • 用户 剑齿虎 2014-2-9 0
    引用 4
    zsx 发表于 2014-2-9 11:40
    404         


    你试试,刚才我删了
  • 管理员 zx.asd 2014-2-9 0
    引用 5
    我想下。

    短信已禁用,有事发贴。

  • 用户 剑齿虎 2014-2-9 0
    引用 6
    zx.asd 发表于 2014-2-9 16:13
    我想下。


    错误码什么的,不是那么设定的吗?用想啊~
  • 管理员 zx.asd 2014-2-9 0
    引用 7

    进入FTP,修改一下zb_system\defend\option.php

    'ZC_DEBUG_MODE' => false,
    改为
    'ZC_DEBUG_MODE' => true,
    再保存,进安装页把错误代码贴上来看下。

    短信已禁用,有事发贴。

  • 用户 剑齿虎 2014-2-9 0
    引用 8
    zx.asd 发表于 2014-2-9 16:18
    进入FTP,修改一下zb_system\defend\option.php

    'ZC_DEBUG_MODE' => false,





    http://desc.yuxiaobo.cn/zb_install/
  • 管理员 zx.asd 2014-2-9 0
    引用 9
    http://www.thinkphp.cn/topic/1722.html

    暗淡亮点05月15日
    自己已经解决,谢谢你给的提醒。当然,这个必须空间提供商允许使用.htaccess时候才有用。
    在根目录增加一个空的php文件,接着在.htaccess中添加这段:php_value auto_prepend_file "null.php" OK。解决了。因为覆盖了空间商默认增加的文件。: )

    短信已禁用,有事发贴。

  • 用户 itdaren 2014-2-16 0
    引用 10
    这个问题,我今天也碰到了,美国的主机,不过现在完美解决。😁
    解决办法:
    1.分析了一下原因,主要国外的主机中PHP配置文件两个选项auto_prepend_file和auto_append_file出了问题,他们默认绑定了/usr/lib/php/head.php和/usr/lib/php/footer.php这两个文件,这一点我们可以从调试模式中的引用文件可以得到印证
    2.由于我们无法更改主机商PHP配置文件,但是我们可以通过.htaccess文件来实现对auto_prepend_file和auto_append_file的修改,写法如下:
    php_value auto_prepend_file "/home/username/public_html/header.php"
    php_value auto_append_file "/home/username/public_html/footer.php"
    将上面两行写进记事本,另存为.htaccess文件(注:username是主机商给你取的用户名)
    3.新建两个空文件,header.php和footer.php文件
    4.最后将.htaccess文件、header.php和footer.php文件上传到public_html下,即可正常安装我们
    Z-BlogPHP啦!!!亲测有效!!!
  • 用户 ShunYea 2014-2-16 0
    引用 11
    好经验学习下。
    • ZBlogger技术交流中心
      12
          
返回