PHP主机版本问题

用户 phenix87 2015-6-30 2043

PHP5.3是未来发展的趋势,最近我就有一个同事帮忙测试一下他下的的网站程序,但上传后结果显示:Your PHP Version is 5.2.17, But WeiPHP require PHP > 5.3.0 !。立刻就郁闷了,只好本地测试……测试结束后发现我机子中原本的PHP程序无法运行!
这就有一个问题了,只是学习或交流的个人网站可能经常测试一些程序,但5.2与5.3的不一定兼容!我查看了一些主机服务商,看到个很实用的功能如下图


在后台对PHP版本实现了版本的切换。这种方法比较人性化,适合学习测试为目的的站长,至少不需要为了测试5.3的程序还要在弄个空间去!!!
不过虽然有商家做了但离普及估计还需要不少时间,毕竟就单独的支持5.3版本的空间都很少😔
最新回复 (5)
全部楼主
  • 管理员 zsx 2015-7-1 0
    引用 2
    是这样的,DBS由于历史原因采用5.2. 你可以手动让客服帮你切到PHP 5.X(没错,这就是人力后台)

    如果某个帖子我已经回复,需要得到我的进一步帮助的话请点击“回复”按钮。程序使用问题及应用中心问题请在论坛发帖。
    如果你认为出现了程序Bug,请直接私聊我:QQ联系。有事直说,不要客套。因免费程序精力不足,咨询类问题一概无视。

  • 用户 nobird 2015-7-1 0
    引用 3
    连续购买2年以上,可以切换到php7✌

    欢迎联系定制服务,qq:8769298

  • 用户 phenix87 2015-7-2 0
    引用 4
    zsx 发表于 2015-7-1 06:49
    是这样的,DBS由于历史原因采用5.2. 你可以手动让客服帮你切到PHP 5.X(没错,这就是人力后台)


    能单独升级到5.3!是找值班客服吗?如果可以我就升级一个,反正我有两个空间!
  • 管理员 zsx 2015-7-3 0
    引用 5
    phenix87 发表于 2015-7-2 21:02
    能单独升级到5.3!是找值班客服吗?如果可以我就升级一个,反正我有两个空间!

    是(大概

    如果某个帖子我已经回复,需要得到我的进一步帮助的话请点击“回复”按钮。程序使用问题及应用中心问题请在论坛发帖。
    如果你认为出现了程序Bug,请直接私聊我:QQ联系。有事直说,不要客套。因免费程序精力不足,咨询类问题一概无视。

  • 用户 很不搭 2017-10-28 0
    引用 6
    都这么长的帖子了
    • ZBlogger技术交流中心
      7
          
返回