ZBlogger技术交流中心

 找回密码
 注册

QQ登录

只需一步,快速开始

Z-BlogPHP 最新开发动态 下载最新版:Z-BlogPHP 1.5 Zero Wordpress转换 - Emlog转换 - 找回密码

Z-BlogASP 最新开发动态 下载最新版:Z-Blog 2.2 Prism Build 140101 转换到Z-BlogPHP - 1.8升级指南 - 找回密码

DBS官方主机/域名/VPS 推荐:Z-BlogPHP主机-Z-BlogASP主机 联系值班客服(每天9:00-21:30)

搜索
【聚划算】宅男最新神器!你懂的!环球外贸论坛
查看: 6178|回复: 41

Z-BlogPHP 1.5 Zero 发布了!!!

[复制链接]
发表于 2016-11-2 08:24:53 | 显示全部楼层 |阅读模式
非常高兴地告诉大家,时隔一年多,Z-BlogPHP 1.5终于发布了。

本次的版本代号为“Zero”,它的意思是化整为零,从零开始;承前启后,继往开来。



针对一般用户而言,最主要的更新内容:

1.持续更新支持
为了与互联网更好地接轨,我们处理了版本号机制,梳理了系统流程。我们希望大家能尽快升级到最新版本的程序,享受最新的功能。当然,老版本的使用仍然不会受任何限制,我们不会设下任何束缚;我们也不会进行强制更新,或者出现烦人的提示。选择权仍然在你的手上。
1.5将是Z-BlogPHP 1.x系列的最后一个版本,接下来除了小版本更新迭代,开发团队将更多专注于2.0版本的开发设计。


2.增强对https与中文域名的支持

https是现在互联网发展的潮流,我们认为每个网站在有条件的情况下都应该打开它。支持说明见:https://blog.zblogcn.com/2016/10/13/84/。1.4版本的https支持对于某些特殊配置的网站存在一些问题,我们在此版本进行了修复。另外,这个版本也加强了对中文域名等的支持。

3.伪静态地址唯一化

曾经我们广受大家诟病的一点是,一篇文章或者分类可能有多个地址均能访问,可能造成内容的重复。在此我们也欣喜地告知大家,这一点现也已修正。

4.错误提示友好化

也许你很喜欢折腾,经常面对着满屏英文“乱码”无法自拔。在这个版本,我们对错误提示进行了友好化处理,预置一些可能的错误原因,并有在线Wiki可供查找,期望对大家有所帮助。
当然,我们也做了全局审核评论开关、升级了验证码、加强用户安全保护机制、处理了模板编译目录等。插件部分,Totoro的相似度检测功能、UEditor的新版代码高亮等,相信大家已经使用过了。我们衷心地希望,这些小的细节体验优化能给大家带来惊喜。

对于开发者而言,新增了若干新特性:

1.侧栏模板化

现在,你可以自定义你的主题中日历等被系统写死的侧栏组件的样式了。详情可参考系统自带defend目录。

2.Z-BlogPHP JavaScript Framework支持

现在,不再拘泥于jQuery 1.8.3,系统自带1.8.3与2.2.4两个版本的jQuery,主题也可以自带任意版本的jQuery,想干就干吧。借由这个框架,我们在前端也引入了插件机制,意图处理混乱的前端js代码。

3.链式SQL调用库

我们新增了“链式SQL”,以替代原先反人类的SQL调用方式。新型书写方式简单自然,一气呵成,想必能直接避免总是不得不查参数的痛苦与调试失败的无奈。

4.错误页升级

错误页现也支持模板了,并且我们更引入了错误堆栈,调试更为方便。



程序升级:
   
    注意:请在升级前做好整站备份!
    打开“应用中心”插件,点击子导航栏的“系统更新与校验”,按提示进行升级或者效验系统文件进行更新。

应用升级指南:



下载:





在线安装程序



回复

使用道具 举报

发表于 2016-11-2 08:43:37 | 显示全部楼层
来的早不如来的巧,沙发了
回复 支持 反对

使用道具 举报

发表于 2016-11-2 09:26:37 | 显示全部楼层
想静态网址
回复 支持 反对

使用道具 举报

发表于 2016-11-2 09:27:12 | 显示全部楼层
现在在用ASP
回复 支持 反对

使用道具 举报

发表于 2016-11-2 10:24:32 | 显示全部楼层
这个必须发表祝贺
回复 支持 反对

使用道具 举报

发表于 2016-11-2 11:04:50 | 显示全部楼层
前来祝贺
回复 支持 反对

使用道具 举报

发表于 2016-11-2 11:33:08 | 显示全部楼层
前排在占位
回复 支持 反对

使用道具 举报

发表于 2016-11-2 11:35:55 | 显示全部楼层
特来恭贺,建议官方尽早出台升级方法,我的刚才升级了下杯具了
回复 支持 反对

使用道具 举报

发表于 2016-11-2 12:44:01 | 显示全部楼层
1.4php版本我就在用https,还不错。1.5php版本希望更好,不过,暂时没有升级的想法,哈哈。。。
回复 支持 反对

使用道具 举报

发表于 2016-11-2 12:46:24 | 显示全部楼层
前排恭贺!
回复 支持 反对

使用道具 举报

发表于 2016-11-2 13:38:27 | 显示全部楼层
全部升级了~
回复 支持 反对

使用道具 举报

发表于 2016-11-2 13:47:08 | 显示全部楼层
支持下。新版本。
回复 支持 反对

使用道具 举报

发表于 2016-11-2 16:33:46 | 显示全部楼层
支持一下辛苦了!
回复 支持 反对

使用道具 举报

发表于 2016-11-2 18:18:59 | 显示全部楼层
必须支持,感谢你的团队,这么好的开源程序
回复 支持 反对

使用道具 举报

发表于 2016-11-2 19:50:14 | 显示全部楼层
世界人民发来核电。。。。
回复 支持 反对

使用道具 举报

发表于 2016-11-2 21:55:36 | 显示全部楼层
强烈支持。。。
回复 支持 反对

使用道具 举报

发表于 2016-11-3 00:09:52 | 显示全部楼层
准备开始学习下php
回复 支持 反对

使用道具 举报

发表于 2016-11-3 06:32:38 | 显示全部楼层
这个一定要支持,希望ZBLOG越做越好
回复 支持 反对

使用道具 举报

发表于 2016-11-3 15:19:24 | 显示全部楼层
支持ZBLOG 一个非常不错的程序,简单!
回复 支持 反对

使用道具 举报

发表于 2016-11-4 11:37:15 | 显示全部楼层
)E_COMPILE_ERROR : Cannot redeclare utf84mb_filter() (previously declared in /home/wwwroot/chukoushuo.com/zb_system/function/c_system_common.php:1292) (register_shutdown_function) (1.5.0.1620 (Zero))

-------
1.4升级1.5后取如上错误,怎么处理?
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则

Archiver|手机版|ZBlogger技术交流中心 ( 鄂ICP备11007414号 鄂公网安备 42060602000101号 )

GMT+8, 2017-11-21 17:54 , Processed in 0.026435 second(s), 4 queries , APCu On.

Powered by Discuz! X3.4

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表