点击[清空缓存并重新编译模板] ,没有反应 使用咨询

用户 huxiti 2016-12-9 2645

本帖最后由 huxiti 于 2016-12-9 12:30 编辑

关于[清空缓存并重新编译模板],曾经反应过点击它会一直打圈圈,现在圈圈没有了,变成没有反应(图1)。


详细情况如下:
发表一篇新文章,点击清空缓存并重新编译模板,没有反应。只有你重新登录后台,点击才能缓存更新。除了重新登录之外,还有一个方法就是重新提交一下网站设置(有时候也不灵),再点击清空缓存并重新编译模板



我用的是阿里云虚拟主机。
目前已经使用的方法有(都无效):
1、PHP环境相关参数版本选择最高;2、php.ini参数设置函数全部启用;3、文件夹权限全部改成777;4、重新安装zblog,重新倒入数据库。


最新回复 (7)
全部楼主
  • 超级版主 沉冰浮水 2016-12-10 0
    引用 2
    首先发表文章后并不需要点这个的,,如果是模块或者什么地方的数据没有自动更新请说明以供解决。。

    沉冰浮水.tk点此加入QQ群 ←_←我大概率能够解决你所实际面临的问题,然而”你提出的问题“却往往是另一个问题。

  • 用户 huxiti 2016-12-10 0
    引用 3
    沉冰浮水 发表于 2016-12-10 11:01
    首先发表文章后并不需要点这个的,,如果是模块或者什么地方的数据没有自动更新请说明以供解决。。


    谢谢你的回复。
    发表文章之后,文章是可以发表,但是文章总数数量不对,停留在发表之前的数量。这时候,需要点击清空缓存并重新编译模板了。重新登录后台,点击清空缓存并重新编译模板,数量才更新
  • 应用开发者 machealx 2016-12-10 0
    引用 4
    你看看你的php.ini有没有开启opcache

    提供网站性能优化,zblog插件及主题定制开发和修改。
    联系QQ:43649260

  • 用户 huxiti 2016-12-10 0
    引用 5
    machealx 发表于 2016-12-10 11:38
    你看看你的php.ini有没有开启opcache

    似乎没有这个选项,不过有个类似的选项。我截图复制过来,你帮我看看。

  • 应用开发者 machealx 2016-12-10 0
    引用 6
    额 原来是虚拟主机- -那跟OPCACHE没关系了

    你这个可能是主题的问题 你不信可以换一个主题试一下

    因为发布文章不需要重新编译的 又不是改模板 所以 换主题解决一切。比如自带主题先试试看

    提供网站性能优化,zblog插件及主题定制开发和修改。
    联系QQ:43649260

  • 用户 huxiti 2016-12-10 0
    引用 7
    machealx 发表于 2016-12-10 15:56
    额 原来是虚拟主机- -那跟OPCACHE没关系了

    你这个可能是主题的问题 你不信可以换一个主题试一下


    谢谢。不行哎。怀疑空间服务器的问题
  • 用户 hanjiansky 2018-4-26 0
    引用 8
    根目录下的 zb_users中的cache文件夹要有写权限
    cd zb_users
    chmod 777 cache
    • ZBlogger技术交流中心
      9
          
返回