我的zblog分类条显示不正常跳转首页分页条各种方法试过来... Z-Blog 2

用户 sgys 2018-1-22 948

本帖最后由 sgys 于 2018-1-23 16:00 编辑

首先介绍一下系统啊
zblog最新版的
正常情况下点击123跳出的会是分类下的文章
数据是emlog转换过来的
问题网址:http://www.qqyum.com/hdzx
你点击下方的1234页码就会发现跳转到首页的分页条了并不是分类下的文章
本人已经试过的方法
伪静态关闭调整(并非伪静态)
动态开启之后照样发现这个错误
模板切换到默认模板以及系统自带三模板也是一个错误
最后一个就是可能我是emlog移民数据库问题
希望大神解答
因为文字原因没有配图大家自行帮忙谢谢


最新回复 (10)
全部楼主
  • 应用开发者 痕迹 2018-1-22 0
    引用 2
    你伪静态配置问题。

    博客吧-zblog教程,主题

  • 用户 sgys 2018-1-23 0
    引用 3
    痕迹 发表于 2018-1-22 19:17
    你伪静态配置问题。


    大哥我动态还是这样
  • 管理员 zsx 2018-1-23 0
    引用 4
    下面那个页码就是分页条啊,不懂你在说什么……

    不理世事

  • 用户 sgys 2018-1-23 0
    引用 5
    zsx 发表于 2018-1-23 15:31
    下面那个页码就是分页条啊,不懂你在说什么……


    大佬你点击123就会发现出现的文章不是分类下的文章是首页的123分页条
  • 应用开发者 痕迹 2018-1-23 0
    引用 6
    sgys 发表于 2018-1-23 15:26
    大哥我动态还是这样


    真的是你伪静态“分类页的URL配置”的配置问题。动态是这样是因为你没有删除生成的伪静态文件

    博客吧-zblog教程,主题

  • 应用开发者 痕迹 2018-1-23 0
    引用 7
    本帖最后由 痕迹 于 2018-1-23 16:11 编辑

    请不要把“分类页的URL配置”中的{%alias%}或者{%id%}删除

    博客吧-zblog教程,主题

  • 用户 sgys 2018-1-23 0
    引用 8
    痕迹 发表于 2018-1-23 16:09
    请不要把“分类页的URL配置”中的{%alias%}或者{%id%}删除


    没有删除哦,我刚才按照你说的试了删除了根目录下的静态配置文件,然后调整成动态的还是老毛病
  • 用户 sgys 2018-1-23 0
    引用 9
    痕迹 发表于 2018-1-23 16:09
    请不要把“分类页的URL配置”中的{%alias%}或者{%id%}删除


    方便留个qq吗?论坛不方便
  • 应用开发者 痕迹 2018-1-23 0
    引用 10
    本帖最后由 痕迹 于 2018-1-23 16:39 编辑

    sgys 发表于 2018-1-23 16:14
    没有删除哦,我刚才按照你说的试了删除了根目录下的静态配置文件,然后调整成动态的还是老毛病 ...

    你的分类分页url显然是不对的。你可以把你的静态中心的伪静态配置截图发上来。如果伪静态配置正确,那就把你主题分页部分的代码截图发上来

    博客吧-zblog教程,主题

  • 用户 sgys 2018-2-16 0
    引用 11
    已经解决是大谋工具箱的bug已经修复
    • ZBlogger技术交流中心
      12
          
返回